Search found 55 matches

by Gene Luzader
Sat Jan 02, 2010 6:38 am
Forum: General Discussion
Topic: 820 NOT PUMPING GAS
Replies: 3
Views: 1631

Re: 820 NOT PUMPING GAS

Jim
It sounds like you have the small vacuum hole from the crankcase to the carb blocked.
Check the gasket alighment and hole position.

Gene Luzader
412-824-8234
by Gene Luzader
Tue Nov 03, 2009 6:39 pm
Forum: General Discussion
Topic: US820 Girdle kits
Replies: 3
Views: 1576

Re: US820 Girdle kits

Louie
I would like a couple pics also.
Gene Luzader
412-824-8234
erluzader@verizon .net
Thanks
by Gene Luzader
Sun Mar 08, 2009 7:48 pm
Forum: General Discussion
Topic: Support and what it means to some.
Replies: 12
Views: 4160

Re: Support and what it means to some.

McBob
I know it would be expensive but that seems to be the best way to get in touch with Dave.
He has spent a lot of extra time on the phone with me in the past. I find thats the best way
to get in touch with him. He has really helped me with setup my 820s.

Gene Luzader
by Gene Luzader
Mon Mar 17, 2008 5:47 pm
Forum: General Discussion
Topic: GO KART PIX OF TWIN ENGINE 63 SIMPLEX KART
Replies: 7
Views: 5277

Re: GO KART PIX OF TWIN ENGINE 63 SIMPLEX KART

Just for info....I got these starter setups from EJ Korecky a few years back. I had to do my own mounts for the original WB Mounting System. EJ's mounts were for a 2 rail kart. This starter setup works great. Gene
by Gene Luzader
Sat Mar 15, 2008 1:38 pm
Forum: General Discussion
Topic: GO KART PIX OF TWIN ENGINE 63 SIMPLEX KART
Replies: 7
Views: 5277

GO KART PIX OF TWIN ENGINE 63 SIMPLEX KART

HERE ARE SOME PIX OF MY 1963 SIMPLEX (TWIN WB820'S) WITH ONBOARD ELECTRIC
STARTERS.
GENE